use strict;
my $str = '0+171235652++zu
or
122+115166747++en';
my $regex = qr/^(\d+)\+.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";