const regex = /^(\d+)\+.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\+.*', 'gm')
const str = `0+171235652++zu
or
122+115166747++en`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);