$re = '/^(\d+)\+.*/m';
$str = '0+171235652++zu
or
122+115166747++en';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;