package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-z0-9.-]@[a-z0-9]{2,}\.[a-z]{2,}`)
var str = `mx_square@shapes
mx_square@shapes.in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}