// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[a-z0-9.-]@[a-z0-9]{2,}\.[a-z]{2,}").unwrap();
let string = "mx_square@shapes
mx_square@shapes.in";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}