re = /[a-z0-9.-]@[a-z0-9]{2,}\.[a-z]{2,}/i
str = 'mx_square@shapes
mx_square@shapes.in'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end