$re = '/[a-z0-9.-]@[a-z0-9]{2,}\.[a-z]{2,}/i';
$str = 'mx_square@shapes
mx_square@shapes.in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);