using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)+o";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit
asdfasdf asdoasdf asdf aso o";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}