re = /(\w)+o/
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit
asdfasdf asdoasdf asdf aso o'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end