# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!http.*)\\/(.*?)\\//[$1]/gm;t' <<< "Lorem // ipsum
https://www.google.com/search?q=lorem+ipsum
/lorem:ipsum/
consecteur /adipiscing/ eu/turpis//velit/ ut/rhoncus/
tincidunt: eget; nibh nam: facilisis; ligula: lacinia
1.
sed at pulvinar ante.
\"cras nec nibh lacus\"
suspendisse potenti
ut pharetra urna sed. \"proin convalis uris\"
phasellus tincidunt
mauris justo iaculis. \"vivamus scelerisque\"
"