use strict;
my $str = 'Lorem // ipsum
https://www.google.com/search?q=lorem+ipsum
/lorem:ipsum/
consecteur /adipiscing/ eu/turpis//velit/ ut/rhoncus/
tincidunt: eget; nibh nam: facilisis; ligula: lacinia
1.
sed at pulvinar ante.
"cras nec nibh lacus"
suspendisse potenti
ut pharetra urna sed. "proin convalis uris"
phasellus tincidunt
mauris justo iaculis. "vivamus scelerisque"
';
my $regex = qr/(?<!http.*)\/(.*?)\//mp;
my $subst = '[$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";