const regex = /(?<!http.*)\/(.*?)\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!http.*)\\\/(.*?)\\\/', 'gm')
const str = `Lorem // ipsum
https://www.google.com/search?q=lorem+ipsum
/lorem:ipsum/
consecteur /adipiscing/ eu/turpis//velit/ ut/rhoncus/
tincidunt: eget; nibh nam: facilisis; ligula: lacinia
1.
sed at pulvinar ante.
"cras nec nibh lacus"
suspendisse potenti
ut pharetra urna sed. "proin convalis uris"
phasellus tincidunt
mauris justo iaculis. "vivamus scelerisque"
`;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);