#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\G(?!\A)=|=(?===)"
Local $sString = "=== == ======= asdlkfj"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)