using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G(?!\A)=|=(?===)";
string substitution = @"-";
string input = @"=== == ======= asdlkfj";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}