const regex = /\G(?!\A)=|=(?===)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G(?!\\A)=|=(?===)', 'g')
const str = `=== == ======= asdlkfj`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);