use strict;
my $str = '=== == ======= asdlkfj';
my $regex = qr/\G(?!\A)=|=(?===)/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";