#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(process started).*?(process id \d{2}).*?(?<!process started)(process completed)"
Local $sString = "process started" & @CRLF & _
"process id 00" & @CRLF & _
"some process details" & @CRLF & _
"process completed" & @CRLF & _
"" & @CRLF & _
"process started" & @CRLF & _
"process id 01" & @CRLF & _
"some process details" & @CRLF & _
"process completed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")