$re = '/(process started).*?(process id \d{2}).*?(?<!process started)(process completed)/ms';
$str = 'process started
process id 00
some process details
process completed
process started
process id 01
some process details
process completed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);