re = /(process started).*?(process id \d{2}).*?(?<!process started)(process completed)/m
str = 'process started
process id 00
some process details
process completed
process started
process id 01
some process details
process completed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end