const regex = /(process started).*?(process id \d{2}).*?(?<!process started)(process completed)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(process started).*?(process id \\d{2}).*?(?<!process started)(process completed)', 'gms')
const str = `process started
process id 00
some process details
process completed
process started
process id 01
some process details
process completed`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}