$re = '/((non-)?(interactive|login) ?){2}/m';
$str = 'interactive login
non-interactive login
interactive non-login
non-interactive non-login';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);