re = /((non-)?(interactive|login) ?){2}/m
str = 'interactive login
non-interactive login
interactive non-login
non-interactive non-login'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end