package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)["']\s*(SELECT)\s*\*\s*(SELECT|FROM)`)
var str = `"SELECT * FROM table"
"
SELECT * FROM table"
"""
Use this query here: "SELECT * FROM table"
"""
SELECT * FROM table`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}