re = /["']\s*(SELECT)\s*\*\s*(SELECT|FROM)/m
str = '"SELECT * FROM table"
"
SELECT * FROM table"
"""
Use this query here: "SELECT * FROM table"
"""
SELECT * FROM table'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end