const regex = /["']\s*(SELECT)\s*\*\s*(SELECT|FROM)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('["\']\\s*(SELECT)\\s*\\*\\s*(SELECT|FROM)', 'gm')
const str = `"SELECT * FROM table"
"
SELECT * FROM table"
"""
Use this query here: "SELECT * FROM table"
"""
SELECT * FROM table`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}