// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)["']\s*(SELECT)\s*\*\s*(SELECT|FROM)"#).unwrap();
let string = "\"SELECT * FROM table\"
\"
SELECT * FROM table\"
\"\"\"
Use this query here: \"SELECT * FROM table\"
\"\"\"
SELECT * FROM table";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}