#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http|https):\/\/(www\.)?.+(?<!discord|docs\.google|facebook|youtube|twitter|app\.plex)\.(com|net|org|tv)(.+)?"
Local $sString = "https://www.facebook.com/username" & @CRLF & _
"https://facebook.com/username" & @CRLF & _
"http://facebook.com/username" & @CRLF & _
"http://www.facebookk.com" & @CRLF & _
"https://www.facebookk.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"https://www.discord.com" & @CRLF & _
"https://www.discord9.com" & @CRLF & _
"https://www.app.plex.tv" & @CRLF & _
"https://docs.google.com" & @CRLF & _
"https://www.twitter.com" & @CRLF & _
"https://fictionaldomain1.com/" & @CRLF & _
"https://www.twitter.com/agsdag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")