using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https):\/\/(www\.)?.+(?<!discord|docs\.google|facebook|youtube|twitter|app\.plex)\.(com|net|org|tv)(.+)?";
string input = @"https://www.facebook.com/username
https://facebook.com/username
http://facebook.com/username
http://www.facebookk.com
https://www.facebookk.com
https://www.google.com
https://www.discord.com
https://www.discord9.com
https://www.app.plex.tv
https://docs.google.com
https://www.twitter.com
https://fictionaldomain1.com/
https://www.twitter.com/agsdag";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}