use strict;
my $str = 'https://www.facebook.com/username
https://facebook.com/username
http://facebook.com/username
http://www.facebookk.com
https://www.facebookk.com
https://www.google.com
https://www.discord.com
https://www.discord9.com
https://www.app.plex.tv
https://docs.google.com
https://www.twitter.com
https://fictionaldomain1.com/
https://www.twitter.com/agsdag';
my $regex = qr/(http|https):\/\/(www\.)?.+(?<!discord|docs\.google|facebook|youtube|twitter|app\.plex)\.(com|net|org|tv)(.+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}