package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d\d\d\d-\d\d-\d\dT\d\d:\d\d:\d\d\.\d\d\d\d\d\d-\d\d:\d\d) (.*?) (.*?): (.*)$`)
var str = `2021-02-17T13:55:32.924454-05:00 web50 systemd-logind[889]: New session 185577 of user mcmac.
2021-02-17T13:55:47.082860-05:00 wev37 sudo: pam_unix(sudo:session): session opened for user root by mcmac(uid=0)
2021-02-17T13:47:52.954190-05:00 apiproxy-test02 systemd: pam_unix(systemd-user:session): session opened for user nate by (uid=0)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}