// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d\d\d\d-\d\d-\d\dT\d\d:\d\d:\d\d\.\d\d\d\d\d\d-\d\d:\d\d) (.*?) (.*?): (.*)$").unwrap();
let string = "2021-02-17T13:55:32.924454-05:00 web50 systemd-logind[889]: New session 185577 of user mcmac.
2021-02-17T13:55:47.082860-05:00 wev37 sudo: pam_unix(sudo:session): session opened for user root by mcmac(uid=0)
2021-02-17T13:47:52.954190-05:00 apiproxy-test02 systemd: pam_unix(systemd-user:session): session opened for user nate by (uid=0)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}