#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[\D]*\d)(?=[^a-zA-Z]*[a-zA-Z])(?=.{6,})(?!.*(\d)\1{2})(?!.*([a-zA-Z])(?:.*?\2){2,}).*$"
Local $sString = "jj112233" & @CRLF & _
"jkhsfsndbf8uwwe" & @CRLF & _
"a1234" & @CRLF & _
"nsds312" & @CRLF & _
"111aaa222" & @CRLF & _
"aa1aa1aa1" & @CRLF & _
"hbsd12" & @CRLF & _
"aa11bbsd" & @CRLF & _
"hgshsadh12" & @CRLF & _
"hh8uqweuu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")