import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[\\D]*\\d)(?=[^a-zA-Z]*[a-zA-Z])(?=.{6,})(?!.*(\\d)\\1{2})(?!.*([a-zA-Z])(?:.*?\\2){2,}).*$";
final String string = "jj112233\n"
+ "jkhsfsndbf8uwwe\n"
+ "a1234\n"
+ "nsds312\n"
+ "111aaa222\n"
+ "aa1aa1aa1\n"
+ "hbsd12\n"
+ "aa11bbsd\n"
+ "hgshsadh12\n"
+ "hh8uqweuu";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}