$re = '/^(?=[\D]*\d)(?=[^a-zA-Z]*[a-zA-Z])(?=.{6,})(?!.*(\d)\1{2})(?!.*([a-zA-Z])(?:.*?\2){2,}).*$/m';
$str = 'jj112233
jkhsfsndbf8uwwe
a1234
nsds312
111aaa222
aa1aa1aa1
hbsd12
aa11bbsd
hgshsadh12
hh8uqweuu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);