#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z-&$]+)(\d{6})(\d+(?:\.\d+)?[PC]E)"
Local $sString = "Tesla" & @CRLF & _
"Audi" & @CRLF & _
"BMW-N2204281200PE" & @CRLF & _
"SUPRA2204241300.75CE" & @CRLF & _
"TATA230612133.50PE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")