re = /([a-zA-Z-&$]+)(\d{6})(\d+(?:\.\d+)?[PC]E)/m
str = 'Tesla
Audi
BMW-N2204281200PE
SUPRA2204241300.75CE
TATA230612133.50PE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end