import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z-&$]+)(\\d{6})(\\d+(?:\\.\\d+)?[PC]E)";
final String string = "Tesla\n"
+ "Audi\n"
+ "BMW-N2204281200PE\n"
+ "SUPRA2204241300.75CE\n"
+ "TATA230612133.50PE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}