$re = '/([a-zA-Z-&$]+)(\d{6})(\d+(?:\.\d+)?[PC]E)/m';
$str = 'Tesla
Audi
BMW-N2204281200PE
SUPRA2204241300.75CE
TATA230612133.50PE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);