using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w\s-_]+\.[\w]{1,4}$";
string input = @".htaccess
.
..
file
file.
fi,le.dat
file#gg.jpg
file.longextension
fi-le.dat
fi_le.dat
file.ext
File.jpg
file.d
file.dd
565gfgf.mov
filegg.jpg
file-gg.jpg
file_gg.jpg
file_gg.mp4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}