// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w\s-_]+\.[\w]{1,4}$").unwrap();
let string = ".htaccess
.
..
file
file.
fi,le.dat
file#gg.jpg
file.longextension
fi-le.dat
fi_le.dat
file.ext
File.jpg
file.d
file.dd
565gfgf.mov
filegg.jpg
file-gg.jpg
file_gg.jpg
file_gg.mp4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}