import Foundation
let pattern = #"^[\w\s-_]+\.[\w]{1,4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
.htaccess
.
..
file
file.
fi,le.dat
file#gg.jpg
file.longextension
fi-le.dat
fi_le.dat
file.ext
File.jpg
file.d
file.dd
565gfgf.mov
filegg.jpg
file-gg.jpg
file_gg.jpg
file_gg.mp4
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)