$re = '/^[\w\s-_]+\.[\w]{1,4}$/m';
$str = '.htaccess
.
..
file
file.
fi,le.dat
file#gg.jpg
file.longextension
fi-le.dat
fi_le.dat
file.ext
File.jpg
file.d
file.dd
565gfgf.mov
filegg.jpg
file-gg.jpg
file_gg.jpg
file_gg.mp4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);