#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<(JeEntity|JeFeld)>"
Local $sString = "" & @CRLF & _
" #region Satz-Definitionen" & @CRLF & _
"<JeEntity>" & @CRLF & _
" public class «EntityName»_Satz" & @CRLF & _
" {" & @CRLF & _
" #region constructor" & @CRLF & _
" public «EntityName»_Satz()" & @CRLF & _
" {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" #endregion" & @CRLF & _
"<JeFeld>" & @CRLF & _
" public «FeldTyp» «FeldNameCSharp» { get; set; }" & @CRLF & _
"</JeFeld>" & @CRLF & _
" }" & @CRLF & _
"</JeEntity>" & @CRLF & _
" #endregion" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")