const regex = /^<(JeEntity|JeFeld)>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^<(JeEntity|JeFeld)>', 'gm')
const str = `
#region Satz-Definitionen
<JeEntity>
public class «EntityName»_Satz
{
#region constructor
public «EntityName»_Satz()
{
}
#endregion
<JeFeld>
public «FeldTyp» «FeldNameCSharp» { get; set; }
</JeFeld>
}
</JeEntity>
#endregion
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}