// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^<(JeEntity|JeFeld)>").unwrap();
let string = "
#region Satz-Definitionen
<JeEntity>
public class «EntityName»_Satz
{
#region constructor
public «EntityName»_Satz()
{
}
#endregion
<JeFeld>
public «FeldTyp» «FeldNameCSharp» { get; set; }
</JeFeld>
}
</JeEntity>
#endregion
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}