#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]{3}\d{7}\b"
Local $sString = "AAA1234567" & @CRLF & _
"aaa0987654" & @CRLF & _
"bbb1234567" & @CRLF & _
"BBB1234567" & @CRLF & _
"AaA1234567" & @CRLF & _
"abcd1234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")