$re = '/^[A-Za-z]{3}\d{7}\b/m';
$str = 'AAA1234567
aaa0987654
bbb1234567
BBB1234567
AaA1234567
abcd1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);