const regex = /^[A-Za-z]{3}\d{7}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z]{3}\\d{7}\\b', 'gm')
const str = `AAA1234567
aaa0987654
bbb1234567
BBB1234567
AaA1234567
abcd1234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}