re = /^[A-Za-z]{3}\d{7}\b/m
str = 'AAA1234567
aaa0987654
bbb1234567
BBB1234567
AaA1234567
abcd1234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end