import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<sign>[+-])?(?<int>\\d(?:[\\d_ ]*\\d+)?)(?:(?:\\s*[,.]\\s*)(?<decimal>\\d(?:[\\d_ ]*\\d+)?))?";
final String string = "25\n"
+ "15,81\n"
+ "94.5498\n"
+ "+897\n"
+ "151 516,561 894\n"
+ "89.9894_56\n"
+ "-9";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}